[Previous Months][Date Index][Thread Index][Join - Register][Login]   Help@Insulin-Pumpers.org
  [Message Prev][Message Next][Thread Prev][Thread Next]   for subscribe/unsubscribe assistance

[IP] Not quitting but close to it

I need some help.  I'm a newbie to the pump.  I've had it for 5 weeks. 
Last night and today I am working through a pump crisis.  My worst fear
about going on the pump is that it would stop working.  Well, the pump
is working but it is not accomplishing its function.  In other words,
the insulin is not getting to my body which in my opinion is just as
bad.  Before going on the pump I had not had a BG over 300 in a year
(I've only had diabeasties for 1 year and 5 months).  So some how in
inserting the quickset something is going wrong.  I am using 6mm QS
with the quicksetter.  The location is just above the belly button
crease - about 1 inch a above that fold.  I don't have very much fat
but I can pinch a good inch there.  Twice I have taken out the "bad"
site to find it never went in.  One time it had gone in but the end of
the cannual was bent.  This is the second time in 5 weeks that I have
had this crisis.  I'm on my 4th site in 24 hours and I'm not sure this
one is good.  I'm not stupid.  I am trainable.  What am I doing wrong? 
I have called my pump trainer but I think you guys might be better at
finding my errors.  I only read the digest so by the time I get this
digest I hope I have a good site going again.

Any suggestions: on what I'm doing wrong?
how to tell if a site is bad before letting bg rise to 300+?
how frequently I will experience bad site crisis like this?
(twice in 5 weeks seems like more than my share :P)

thanks in advance,

ps i'm not giving up on the pump but i'd be lying if the thought didn't
cross my mind.

Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
for HELP or to subscribe/unsubscribe/change list versions,
contact: HELP@insulin-pumpers.org