[Previous Months][Date Index][Thread Index][Join - Register][Login]
[Message Prev][Message Next][Thread Prev][Thread Next]

RE: [IP] Anyone had trouble with their 508?

"Andy Johnson" <email @ redacted> wrote:

>My MiniMed 508 died on me Monday night @ 7:00 PM.  I was trying to give a 
>bolus for dinner and low and behold,  all sorts of weird stuff happened.  
>Each time I pushed a button (any button), the screen would go blank then 
>flash with the whole display filled with information.
>I received a replacement from MM yesterday (11:00 AM), and it had a problem 
>also.  I am still using it, although the down button (and also the light) 
>does not work.  I have since ordered a loaner, and requested that I get my 
>old pump back once it is fixed.
>I am pleased with the promptness of the replacement pump arrival, however, 
>an very concerned about the testing that goes into the reconditioned 
>(replacement) pumps.
>Has anyone had this same problem with their 508?
>Get your FREE download of MSN Explorer at http://explorer.msn.com
>for HELP or to subscribe/unsubscribe, contact: HELP@insulin-pumpers.org
>send a DONATION http://www.Insulin-Pumpers.org/donate.shtml

Andy....I had the same problem with my minimed 507.  When I tried to give a bolus, the screen went blank for a second and then I got a full screen that flashed before the time screen came back again.  I called minimed and got a loaner pump the very next morning.  I sent my 507 back and when it is fixed they will return it to me.  I also was pleased with how quickly I received a loaner pump.  I only had to give 4 needles to cover boluses before the loaner arrived.  My 507 was still delivering my basal rates!

for HELP or to subscribe/unsubscribe, contact: HELP@insulin-pumpers.org
send a DONATION http://www.Insulin-Pumpers.org/donate.shtml