[Previous Months][Date Index][Thread Index][Join - Register][Login]
  [Message Prev][Message Next][Thread Prev][Thread Next]

Re: [IP] ongoing site problems

The inserter is sometimes the problem with sils - think it goes in too fast
and deep causing the cannula to kink. I gave up on the inserter for this
reason plus it caused me to have trauma putting it up to my skin and
chickening out several times before actually injecting it. I self insert now
and do better all around!
I don't know if you have somebody else in your home - but I have my husband
put sites on my back behind the love handles. Just make sure you can
hook/unhook them by yourself. You can also go above your pubic line too.
Sils really work for me but sometimes one thing or another goes wrong - Do
you have a bad reservoir, had a few bad ones lately too. I hope you find it
out soon -

Sometimes MM will send you replacements if you complain - and they will want
the ones that have something wrong with them. MM will ship you a package and
container to send them back in. Take Care Sharon B
----- Original Message -----
From: "Barbara Ziegler" <email @ redacted>
To: <email @ redacted>
Sent: Sunday, April 06, 2003 1:53 PM
Subject: [IP] ongoing site problems

> I have been having great difficulties with my sites, and am looking for
> I use a MM 507C, sillouettes, and an inserter.  I have been pumping for 10
> years, and using sils for about 3 years.  Part of the problem is scar
> tissue--I can no longer use my lower abdomen.  I am slim, and short, so
> areas are limited.  I'm using my flank mostly, and some tries at upper
> (this is a problem because of little fat, though.)
> I have been having bad sites, and don't know what the problem is.
Yesterday I
> changed 4 times (#5 is in today) because of very high BG and ketones.  The
> cannulas were not kinked or bent, but there was a small amount of blood on
> of them.  These weren't in scar tissue areas, so absorption should have
> good.  The angle of insertion may be a problem, but I'm an experienced
> and am not really doing anything different. I also have had times when the
> site is fine for 24 hours or so, and then apparently something changes
> my BG's go up to the 300-400s plus ketones.
> Can anybody help?  I have talked to my physician's office, and MM, but no
> genuine help.  The pump is OK, the insulin is OK, and I haven't been ill.
> Plus this is a sporadic problem over many months.  I'm very frustrated
> I can't figure it out. Changing out sites this many times costs a lot in
> and money, plus the high blood sugar problems certainly concern me.
> Barbara Ziegler
> ----------------------------------------------------------
> for HELP or to subscribe/unsubscribe, contact:
> HELP@insulin-pumpers.org
for HELP or to subscribe/unsubscribe, contact: