[Previous Months][Date Index][Thread Index][Join - Register][Login]
[Message Prev][Message Next][Thread Prev][Thread Next]

[IP] 507C-No Alarm given for No Delivery---Help!

I have had three no delivery show on my screen in the last three days for 
which no alarm sounded.  The first one went unnoticed.  The second one and 
third one I noticed because when I went back to bolus more for my meal, the 
no delivery was on the screen but no alarm going.  Each time, I bloused for 
what I did not receive and the pump was fine.  During all this my BG was OK.  
I called MM and they told me to not use the pump.  I explained that this only 
happened when I bloused for a meal.  It is Sat. and they will send me a 
loaner on Mon.  I called my endo and he told me to use H for my meals and at 
bedtime take 8U of N until then if that is what it wished to do.  I changed 
the set and I have not had a problem since then.  What to do.  

I received my first 507C in July, 99.  In Oct 99, MM replaced my 507C because 
it was losing time.  We are now in April and they are going to fix this one 
or let me keep the loaner.  This thing was over 5000.00---1200.00 of which 
was my money.  I am very disappointed and not very confident anymore.  Two 
new pumps with serious problems and now they are going to only fix it rather 
than replace it.  Shouldn't I expect better performance from the pump in this 
short period of time?  I take excellent care of it.  They said they couldn't 
replace if they wanted because they do not make the 507C anymore.  

for HELP or to subscribe/unsubscribe, contact: HELP@insulin-pumpers.org
send a DONATION http://www.Insulin-Pumpers.org/donate.shtml